Admin Dashboard Critical disruption
Incident Report for Futurae
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 12:03 CEST
Investigating
We are currently investigating the issue.
Posted Apr 18, 2024 - 11:51 CEST
This incident affected: Futurae Admin.